Strabon

changeset 1511:f5e6db1a2ca6

Moved "apache commons" dependencies from runtime to endpoint.
author Panayiotis Smeros <psmeros@di.uoa.gr>
date Wed Apr 29 13:09:23 2015 +0300 (2015-04-29)
parents 4b2c4f8cb7fa
children 87172a83de76
files endpoint/pom.xml
line diff
     1.1 --- a/endpoint/pom.xml	Wed Apr 29 12:58:44 2015 +0300
     1.2 +++ b/endpoint/pom.xml	Wed Apr 29 13:09:23 2015 +0300
     1.3 @@ -45,6 +45,48 @@
     1.4  				</exclusion>
     1.5  			</exclusions>
     1.6  		</dependency>
     1.7 +
     1.8 +		<!-- Apache Commons -->
     1.9 +		<dependency>
    1.10 +			<groupId>commons-cli</groupId>
    1.11 +			<artifactId>commons-cli</artifactId>
    1.12 +		</dependency>
    1.13 +		<dependency>
    1.14 +			<groupId>commons-dbcp</groupId>
    1.15 +			<artifactId>commons-dbcp</artifactId>
    1.16 +		</dependency>
    1.17 +		<dependency>
    1.18 +			<groupId>commons-fileupload</groupId>
    1.19 +			<artifactId>commons-fileupload</artifactId>
    1.20 +		</dependency>
    1.21 +		<dependency>
    1.22 +			<groupId>commons-io</groupId>
    1.23 +			<artifactId>commons-io</artifactId>
    1.24 +			<!-- this is the version that is specified as an optional dependency for 
    1.25 +				fileupload -->
    1.26 +		</dependency>
    1.27 +		<dependency>
    1.28 +			<groupId>commons-httpclient</groupId>
    1.29 +			<artifactId>commons-httpclient</artifactId>
    1.30 +			<exclusions>
    1.31 +				<exclusion>
    1.32 +					<groupId>commons-logging</groupId>
    1.33 +					<artifactId>commons-logging</artifactId>
    1.34 +				</exclusion>
    1.35 +				<exclusion>
    1.36 +					<!-- httpclient includes older codec -->
    1.37 +					<groupId>commons-codec</groupId>
    1.38 +					<artifactId>commons-codec</artifactId>
    1.39 +				</exclusion>
    1.40 +			</exclusions>
    1.41 +		</dependency>
    1.42 +		<dependency>
    1.43 +			<groupId>commons-codec</groupId>
    1.44 +			<artifactId>commons-codec</artifactId>
    1.45 +			<scope>runtime</scope>
    1.46 +		</dependency>
    1.47 +		<!-- Apache Commons -->
    1.48 +		 
    1.49   		
    1.50  		<!-- GeoTools -->
    1.51  		<dependency>