Strabon

changeset 1514:c009d1364185

Cleaned endpoint dependencies.
author Panayiotis Smeros <psmeros@di.uoa.gr>
date Wed Apr 29 13:26:26 2015 +0300 (2015-04-29)
parents d3c7d8fab4ec
children f05db489a8b9
files endpoint/pom.xml runtime/pom.xml
line diff
     1.1 --- a/endpoint/pom.xml	Wed Apr 29 13:18:24 2015 +0300
     1.2 +++ b/endpoint/pom.xml	Wed Apr 29 13:26:26 2015 +0300
     1.3 @@ -18,12 +18,8 @@
     1.4  	</properties>
     1.5  
     1.6  	<dependencies>
     1.7 -		<dependency>
     1.8 -			<groupId>javax</groupId>
     1.9 -			<artifactId>javaee-web-api</artifactId>
    1.10 -			<scope>provided</scope>
    1.11 -		</dependency>
    1.12  
    1.13 +		<!-- Core Dependencies -->	
    1.14  		<dependency>
    1.15  			<groupId>eu.earthobservatory</groupId>
    1.16  			<artifactId>strabon-vocabulary</artifactId>
    1.17 @@ -34,93 +30,27 @@
    1.18  			<artifactId>strabon-runtime</artifactId>
    1.19  			<type>jar</type>
    1.20  			<scope>compile</scope>
    1.21 -			<exclusions>
    1.22 -				<exclusion>
    1.23 -					<artifactId>servlet-api-2.5</artifactId>
    1.24 -					<groupId>org.mortbay.jetty</groupId>
    1.25 -				</exclusion>
    1.26 -				<exclusion>
    1.27 -					<artifactId>jsp-api-2.1</artifactId>
    1.28 -					<groupId>org.mortbay.jetty</groupId>
    1.29 -				</exclusion>
    1.30 -			</exclusions>
    1.31  		</dependency>
    1.32 +		<!-- Core Dependencies -->
    1.33  
    1.34 +		<!-- Java -->
    1.35 +		<dependency>
    1.36 +			<groupId>javax</groupId>
    1.37 +			<artifactId>javaee-web-api</artifactId>
    1.38 +			<scope>provided</scope>
    1.39 +		</dependency>
    1.40 +		<!-- Java -->
    1.41 +		
    1.42  		<!-- Apache Commons -->
    1.43  		<dependency>
    1.44 -			<groupId>commons-cli</groupId>
    1.45 -			<artifactId>commons-cli</artifactId>
    1.46 -		</dependency>
    1.47 -		<dependency>
    1.48 -			<groupId>commons-dbcp</groupId>
    1.49 -			<artifactId>commons-dbcp</artifactId>
    1.50 -		</dependency>
    1.51 -		<dependency>
    1.52  			<groupId>commons-fileupload</groupId>
    1.53  			<artifactId>commons-fileupload</artifactId>
    1.54  		</dependency>
    1.55  		<dependency>
    1.56  			<groupId>commons-io</groupId>
    1.57  			<artifactId>commons-io</artifactId>
    1.58 -			<!-- this is the version that is specified as an optional dependency for 
    1.59 -				fileupload -->
    1.60 -		</dependency>
    1.61 -		<dependency>
    1.62 -			<groupId>commons-httpclient</groupId>
    1.63 -			<artifactId>commons-httpclient</artifactId>
    1.64 -			<exclusions>
    1.65 -				<exclusion>
    1.66 -					<groupId>commons-logging</groupId>
    1.67 -					<artifactId>commons-logging</artifactId>
    1.68 -				</exclusion>
    1.69 -				<exclusion>
    1.70 -					<!-- httpclient includes older codec -->
    1.71 -					<groupId>commons-codec</groupId>
    1.72 -					<artifactId>commons-codec</artifactId>
    1.73 -				</exclusion>
    1.74 -			</exclusions>
    1.75 -		</dependency>
    1.76 -		<dependency>
    1.77 -			<groupId>commons-codec</groupId>
    1.78 -			<artifactId>commons-codec</artifactId>
    1.79 -			<scope>runtime</scope>
    1.80  		</dependency>
    1.81  		<!-- Apache Commons -->
    1.82 -		 
    1.83 - 		
    1.84 -		<!-- GeoTools -->
    1.85 -		<dependency>
    1.86 -			<groupId>org.geotools.xsd</groupId>
    1.87 -			<artifactId>gt-xsd-kml</artifactId>
    1.88 -		</dependency>
    1.89 -
    1.90 -		<dependency>
    1.91 -			<groupId>org.geotools</groupId>
    1.92 -			<artifactId>gt-xml</artifactId>
    1.93 -		</dependency>
    1.94 -
    1.95 -		<dependency>
    1.96 -			<groupId>org.geotools</groupId>
    1.97 -			<artifactId>gt-epsg-hsql</artifactId>
    1.98 -		</dependency>
    1.99 -		<dependency>
   1.100 -			<groupId>org.geotools</groupId>
   1.101 -			<artifactId>gt-shapefile</artifactId>
   1.102 -		</dependency>
   1.103 -
   1.104 -		<!-- Testing: JUnit -->
   1.105 -		<dependency>
   1.106 -			<groupId>junit</groupId>
   1.107 -			<artifactId>junit</artifactId>
   1.108 -			<scope>test</scope>
   1.109 -		</dependency>
   1.110 -
   1.111 -		<!-- JDBC Drivers -->
   1.112 -
   1.113 -		<dependency>
   1.114 -			<groupId>postgresql</groupId>
   1.115 -			<artifactId>postgresql</artifactId>
   1.116 -		</dependency>
   1.117  
   1.118  		<!-- Spring framework -->
   1.119  		<dependency>
   1.120 @@ -143,11 +73,7 @@
   1.121  				</exclusion>
   1.122  			</exclusions>
   1.123  		</dependency>
   1.124 -
   1.125 -		<dependency>
   1.126 -			<groupId>commons-validator</groupId>
   1.127 -			<artifactId>commons-validator</artifactId>
   1.128 -		</dependency>
   1.129 +		<!-- Spring framework -->
   1.130  	</dependencies>
   1.131  
   1.132  	<build>
     2.1 --- a/runtime/pom.xml	Wed Apr 29 13:18:24 2015 +0300
     2.2 +++ b/runtime/pom.xml	Wed Apr 29 13:26:26 2015 +0300
     2.3 @@ -16,7 +16,7 @@
     2.4  
     2.5  	<dependencies>
     2.6  
     2.7 -		<!-- Core dependencies -->
     2.8 +		<!-- Core Dependencies -->
     2.9  		<dependency>
    2.10  			<groupId>org.openrdf.sesame</groupId>
    2.11  			<artifactId>sesame-repository-sail</artifactId>
    2.12 @@ -41,7 +41,7 @@
    2.13  			<groupId>org.openrdf.sesame</groupId>
    2.14  			<artifactId>sesame-queryalgebra-evaluation-spatial</artifactId>
    2.15  		</dependency>
    2.16 -		<!-- Core dependencies -->
    2.17 +		<!-- Core Dependencies -->
    2.18  		
    2.19  		<!-- rio API -->
    2.20  		<dependency>