Strabon

view pom.xml @ 6:23e6ac4be21d

Added dependencies to RDF parsers in main pom.xml
author Babis Nikolaou <charnik@di.uoa.gr>
date Thu Feb 02 20:07:45 2012 +0200 (2012-02-02)
parents ca4328324835
children b6efeb63fa65
line source
1 <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
3 <modelVersion>4.0.0</modelVersion>
5 <groupId>eu.earthobservatory</groupId>
6 <artifactId>strabon</artifactId>
7 <version>3.1.2-SNAPSHOT</version>
8 <packaging>pom</packaging>
10 <parent>
11 <groupId>org.openrdf</groupId>
12 <artifactId>openrdf-root-pom</artifactId>
13 <version>5</version>
14 </parent>
16 <name>Strabon</name>
17 <description>Strabon is a storage and query evaluation module for stRDF/stSPARQL.</description>
18 <url>http://www.strabon.di.uoa.gr/</url>
19 <inceptionYear>2008</inceptionYear>
21 <modules>
22 <module>evaluation</module>
23 <module>runtime</module>
24 <module>postgis</module>
25 <module>monetdb</module>
26 <module>generaldb</module>
27 <module>resultio</module>
28 <module>jars</module>
29 </modules>
31 <properties>
32 <sesame.version>2.6.3</sesame.version>
33 <eu.earthobservatory.version>3.1.2-SNAPSHOT</eu.earthobservatory.version>
34 <aduna.appbase.version>3.5.0</aduna.appbase.version>
35 <slf4j.version>1.6.1</slf4j.version>
36 <spring.version>2.5.6</spring.version>
37 <geotools.version>2.6.6</geotools.version>
38 </properties>
40 <dependencyManagement>
41 <dependencies>
43 <dependency>
44 <groupId>org.openrdf.sesame</groupId>
45 <artifactId>sesame-repository-sail</artifactId>
46 <version>${sesame.version}</version>
47 </dependency>
49 <dependency>
50 <groupId>eu.earthobservatory</groupId>
51 <artifactId>strabon-runtime</artifactId>
52 <version>${eu.earthobservatory.version}</version>
53 </dependency>
55 <dependency>
56 <groupId>org.openrdf.sesame</groupId>
57 <artifactId>sesame-queryresultio-sparqlxml-spatial</artifactId>
58 <version>${eu.earthobservatory.version}</version>
59 </dependency>
61 <dependency>
62 <groupId>org.openrdf.sesame</groupId>
63 <artifactId>sesame-queryalgebra-evaluation-spatial</artifactId>
64 <version>${eu.earthobservatory.version}</version>
65 </dependency>
67 <dependency>
68 <groupId>org.openrdf.sesame</groupId>
69 <artifactId>sesame-sail-postgis</artifactId>
70 <version>${eu.earthobservatory.version}</version>
71 </dependency>
73 <dependency>
74 <groupId>org.openrdf.sesame</groupId>
75 <artifactId>sesame-sail-monetdb</artifactId>
76 <version>${eu.earthobservatory.version}</version>
77 </dependency>
79 <dependency>
80 <groupId>org.openrdf.sesame</groupId>
81 <artifactId>sesame-sail-generaldb</artifactId>
82 <version>${eu.earthobservatory.version}</version>
83 </dependency>
84 <!-- OpenRDF modules -->
85 <dependency>
86 <groupId>org.openrdf.sesame</groupId>
87 <artifactId>sesame-queryalgebra</artifactId>
88 <version>${sesame.version}</version>
89 </dependency>
91 <dependency>
92 <groupId>org.openrdf.sesame</groupId>
93 <artifactId>sesame-queryalgebra-evaluation</artifactId>
94 <version>${sesame.version}</version>
95 </dependency>
97 <dependency>
98 <groupId>org.openrdf.sesame</groupId>
99 <artifactId>sesame-queryalgebra-model</artifactId>
100 <version>${sesame.version}</version>
101 </dependency>
103 <dependency>
104 <groupId>org.openrdf.sesame</groupId>
105 <artifactId>sesame-queryalgebra-evaluation</artifactId>
106 <version>${sesame.version}</version>
107 </dependency>
109 <dependency>
110 <groupId>org.openrdf.sesame</groupId>
111 <artifactId>sesame-queryparser-api</artifactId>
112 <version>${sesame.version}</version>
113 </dependency>
115 <dependency>
116 <groupId>org.openrdf.sesame</groupId>
117 <artifactId>sesame-queryparser-sparql</artifactId>
118 <version>${sesame.version}</version>
119 </dependency>
121 <dependency>
122 <groupId>org.openrdf.sesame</groupId>
123 <artifactId>sesame-model</artifactId>
124 <version>${sesame.version}</version>
125 </dependency>
127 <dependency>
128 <groupId>org.openrdf.sesame</groupId>
129 <artifactId>sesame-sail-api</artifactId>
130 <version>${sesame.version}</version>
131 </dependency>
133 <dependency>
134 <groupId>org.openrdf.sesame</groupId>
135 <artifactId>sesame-query</artifactId>
136 <version>${sesame.version}</version>
137 </dependency>
139 <dependency>
140 <groupId>org.openrdf.sesame</groupId>
141 <artifactId>sesame-sail-rdbms</artifactId>
142 <version>${sesame.version}</version>
143 </dependency>
145 <!-- rio API -->
146 <dependency>
147 <groupId>org.openrdf.sesame</groupId>
148 <artifactId>sesame-rio-rdfxml</artifactId>
149 <version>${sesame.version}</version>
150 </dependency>
152 <dependency>
153 <groupId>org.openrdf.sesame</groupId>
154 <artifactId>sesame-rio-ntriples</artifactId>
155 <version>${sesame.version}</version>
156 </dependency>
158 <dependency>
159 <groupId>org.openrdf.sesame</groupId>
160 <artifactId>sesame-rio-turtle</artifactId>
161 <version>${sesame.version}</version>
162 </dependency>
164 <dependency>
165 <groupId>org.openrdf.sesame</groupId>
166 <artifactId>sesame-rio-trig</artifactId>
167 <version>${sesame.version}</version>
168 </dependency>
169 <!-- rio API -->
171 <!--
172 <dependency>
173 <groupId>info.aduna.commons</groupId>
174 <artifactId>aduna-commons-lang</artifactId>
175 <version>2.10.0-SNAPSHOT</version>
176 </dependency>
177 -->
179 <!-- Aduna Commons -->
180 <!-- Note: other Aduna Commons dependencies are imported from appbase -->
181 <dependency>
182 <groupId>info.aduna.commons</groupId>
183 <artifactId>aduna-commons-collections</artifactId>
184 <version>2.8.0</version>
185 </dependency>
186 <dependency>
187 <groupId>info.aduna.commons</groupId>
188 <artifactId>aduna-commons-concurrent</artifactId>
189 <version>2.7.0</version>
190 </dependency>
191 <dependency>
192 <groupId>info.aduna.commons</groupId>
193 <artifactId>aduna-commons-i18n</artifactId>
194 <version>1.4.0</version>
195 </dependency>
196 <dependency>
197 <groupId>info.aduna.commons</groupId>
198 <artifactId>aduna-commons-iteration</artifactId>
199 <version>2.10.0</version>
200 </dependency>
201 <dependency>
202 <groupId>info.aduna.commons</groupId>
203 <artifactId>aduna-commons-net-http-server-embedded</artifactId>
204 <version>2.5.0</version>
205 </dependency>
207 <!-- Apache Commons -->
208 <dependency>
209 <groupId>commons-cli</groupId>
210 <artifactId>commons-cli</artifactId>
211 <version>1.2</version>
212 </dependency>
213 <dependency>
214 <groupId>commons-dbcp</groupId>
215 <artifactId>commons-dbcp</artifactId>
216 <version>1.3</version>
217 </dependency>
218 <dependency>
219 <groupId>commons-fileupload</groupId>
220 <artifactId>commons-fileupload</artifactId>
221 <version>1.2.1</version>
222 </dependency>
223 <dependency>
224 <groupId>commons-io</groupId>
225 <artifactId>commons-io</artifactId>
226 <!-- this is the version that is specified as an optional dependency
227 for fileupload -->
228 <version>1.3.2</version>
229 </dependency>
230 <dependency>
231 <groupId>commons-httpclient</groupId>
232 <artifactId>commons-httpclient</artifactId>
233 <version>3.1</version>
234 <exclusions>
235 <exclusion>
236 <groupId>commons-logging</groupId>
237 <artifactId>commons-logging</artifactId>
238 </exclusion>
239 <exclusion>
240 <!-- httpclient includes older codec -->
241 <groupId>commons-codec</groupId>
242 <artifactId>commons-codec</artifactId>
243 </exclusion>
244 </exclusions>
245 </dependency>
246 <dependency>
247 <groupId>commons-codec</groupId>
248 <artifactId>commons-codec</artifactId>
249 <version>1.4</version>
250 <scope>runtime</scope>
251 </dependency>
253 <!-- Spring framework -->
254 <dependency>
255 <groupId>org.springframework</groupId>
256 <artifactId>spring-aop</artifactId>
257 <version>${spring.version}</version>
258 <exclusions>
259 <exclusion>
260 <groupId>commons-logging</groupId>
261 <artifactId>commons-logging</artifactId>
262 </exclusion>
263 </exclusions>
264 </dependency>
266 <!-- Compliance tests -->
267 <dependency>
268 <groupId>edu.lehigh.swat.bench</groupId>
269 <artifactId>uba</artifactId>
270 <version>1.7</version>
271 </dependency>
272 <dependency>
273 <groupId>edu.lehigh.swat.bench</groupId>
274 <artifactId>ubt</artifactId>
275 <version>1.1</version>
276 </dependency>
278 <!-- JDBC Drivers -->
279 <dependency>
280 <groupId>postgresql</groupId>
281 <artifactId>postgresql</artifactId>
282 <version>9.0-801.jdbc4</version>
283 </dependency>
285 <dependency>
286 <groupId>mysql</groupId>
287 <artifactId>mysql-connector-java</artifactId>
288 <version>5.1.15</version>
289 </dependency>
291 <!-- various -->
292 <dependency>
293 <groupId>cglib</groupId>
294 <artifactId>cglib</artifactId>
295 <version>2.2</version>
296 </dependency>
298 <!-- GeoTools -->
299 <dependency>
300 <groupId>org.geotools.xsd</groupId>
301 <artifactId>gt-xsd-kml</artifactId>
302 <version>${geotools.version}</version>
303 </dependency>
305 <dependency>
306 <groupId>org.geotools</groupId>
307 <artifactId>gt-xml</artifactId>
308 <version>${geotools.version}</version>
309 </dependency>
311 <dependency>
312 <groupId>org.geotools</groupId>
313 <artifactId>gt-epsg-hsql</artifactId>
314 <version>${geotools.version}</version>
315 </dependency>
316 <dependency>
317 <groupId>org.geotools</groupId>
318 <artifactId>gt-shapefile</artifactId>
319 <version>${geotools.version}</version>
320 </dependency>
322 <dependency>
323 <groupId>org.geotools</groupId>
324 <artifactId>gt-referencing</artifactId>
325 <version>${geotools.version}</version>
326 </dependency>
328 <dependency>
329 <groupId>org.geotools</groupId>
330 <artifactId>gt-jts-wrapper</artifactId>
331 <version>${geotools.version}</version>
332 </dependency>
334 <dependency>
335 <groupId>org.opengis</groupId>
336 <artifactId>geoapi</artifactId>
337 <version>2.2.0</version>
338 </dependency>
340 <!-- Testing: JUnit -->
341 <dependency>
342 <groupId>junit</groupId>
343 <artifactId>junit</artifactId>
344 <version>4.7</version>
345 <scope>test</scope>
346 </dependency>
348 <!-- SLF4J -->
349 <dependency>
350 <groupId>org.slf4j</groupId>
351 <artifactId>slf4j-api</artifactId>
352 <version>${slf4j.version}</version>
353 </dependency>
355 <dependency>
356 <groupId>org.slf4j</groupId>
357 <artifactId>slf4j-simple</artifactId>
358 <version>${slf4j.version}</version>
359 </dependency>
361 </dependencies>
362 </dependencyManagement>
364 <build>
365 <pluginManagement>
366 <plugins>
367 <!-- FIXME: version 2.2-beta-2 causes a lot problems -->
368 <plugin>
369 <groupId>org.apache.maven.plugins</groupId>
370 <artifactId>maven-assembly-plugin</artifactId>
371 <version>2.2-beta-1</version>
372 </plugin>
373 </plugins>
374 </pluginManagement>
376 <plugins>
377 <plugin>
378 <groupId>org.apache.maven.plugins</groupId>
379 <artifactId>maven-compiler-plugin</artifactId>
380 <configuration>
381 <source>1.6</source>
382 <target>1.6</target>
383 <encoding>utf8</encoding>
384 </configuration>
385 </plugin>
386 <!-- <plugin> <groupId>ch.elca.el4j.maven.plugins</groupId> <artifactId>maven-depgraph-plugin</artifactId>
387 <configuration> <outDir>target/site/images</outDir> <dotFile>${pom.artifactId}.dot</dotFile>
388 <outFile>${pom.artifactId}.png</outFile> <filterEmptyArtifacts>true</filterEmptyArtifacts>
389 </configuration> </plugin> -->
390 <plugin>
391 <artifactId>maven-release-plugin</artifactId>
392 <version>2.2.2</version>
393 <configuration>
394 <tagNameFormat>v@{project.version}</tagNameFormat>
395 <autoVersionSubmodules>true</autoVersionSubmodules>
396 </configuration>
397 </plugin>
398 </plugins>
399 </build>
401 <reporting>
402 <plugins>
403 <plugin>
404 <groupId>org.apache.maven.plugins</groupId>
405 <artifactId>maven-javadoc-plugin</artifactId>
406 <configuration>
407 <source>1.6</source>
408 <encoding>utf8</encoding>
409 </configuration>
410 </plugin>
411 </plugins>
412 </reporting>
415 <!-- <pluginRepositories> <pluginRepository> <id>elca-services</id> <url>http://el4.elca-services.ch/el4j/maven2repository</url>
416 <releases> <enabled>true</enabled> </releases> </pluginRepository> </pluginRepositories> -->
418 <scm>
419 <connection>scm:hg:http://hg.strabon.di.uoa.gr/Strabon/</connection>
420 <developerConnection>scm:hg:ssh://hg.strabon.di.uoa.gr///opt/hg/Strabon/</developerConnection>
421 <url>http://hg.strabon.di.uoa.gr/Strabon/</url>
422 </scm>
424 <repositories>
425 <repository>
426 <releases>
427 <enabled>true</enabled>
428 </releases>
429 <snapshots>
430 <enabled>false</enabled>
431 </snapshots>
432 <id>strabon</id>
433 <name>Strabon - maven repository</name>
434 <url>http://maven.strabon.di.uoa.gr/content/repositories/releases</url>
435 </repository>
436 <repository>
437 <releases>
438 <enabled>false</enabled>
439 </releases>
440 <snapshots>
441 <enabled>true</enabled>
442 </snapshots>
443 <id>strabon</id>
444 <name>Strabon - maven repository - snapshots</name>
445 <url>http://maven.strabon.di.uoa.gr/content/repositories/snapshots</url>
446 </repository>
449 <repository>
450 <releases>
451 <enabled>true</enabled>
452 </releases>
453 <snapshots>
454 <enabled>false</enabled>
455 </snapshots>
456 <id>aduna-opensource.releases</id>
457 <name>Aduna Open Source - Maven releases</name>
458 <url>http://repo.aduna-software.org/maven2/releases</url>
459 </repository>
460 <repository>
461 <releases>
462 <enabled>false</enabled>
463 </releases>
464 <snapshots>
465 <enabled>true</enabled>
466 </snapshots>
467 <id>aduna-opensource.snapshots</id>
468 <name>Aduna Open Source - Maven snapshots</name>
469 <url>http://repo.aduna-software.org/maven2/snapshots</url>
470 </repository>
471 <repository>
472 <snapshots>
473 <enabled>true</enabled>
474 </snapshots>
475 <id>opengeo</id>
476 <name>OpenGeo Maven Repository</name>
477 <url>http://download.osgeo.org/webdav/geotools/</url>
478 </repository>
479 </repositories>
481 <distributionManagement>
482 <repository>
483 <id>strabon</id>
484 <name>Strabon maven repo</name>
485 <url>http://maven.strabon.di.uoa.gr/content/repositories/releases</url>
486 </repository>
487 <snapshotRepository>
488 <id>strabon.snapshot</id>
489 <name>Strabon maven repo</name>
490 <url>http://maven.strabon.di.uoa.gr/content/repositories/snapshots</url>
491 </snapshotRepository>
492 </distributionManagement>
493 </project>