Strabon

diff pom.xml @ 308:7f1078abc31f

Added the Geonames parser
author Kostis Kyzirakos <kkyzir@di.uoa.gr>
date Wed Jun 20 19:03:13 2012 +0300 (2012-06-20)
parents c91ab390b86d
children cb46cec15d7b
line diff
     1.1 --- a/pom.xml	Wed Jun 20 16:48:18 2012 +0300
     1.2 +++ b/pom.xml	Wed Jun 20 19:03:13 2012 +0300
     1.3 @@ -45,7 +45,7 @@
     1.4  
     1.5  	<dependencyManagement>
     1.6  		<dependencies>
     1.7 -			<!-- Strabon dependencies -->
     1.8 +			<!-- Strabon dependencies -->			
     1.9  			<dependency>
    1.10  				<groupId>org.openrdf.sesame</groupId>
    1.11  				<artifactId>sesame-queryalgebra-evaluation-spatial</artifactId>
    1.12 @@ -91,6 +91,12 @@
    1.13  			<!-- Sesame dependencies -->
    1.14  			<dependency>
    1.15  				<groupId>org.openrdf.sesame</groupId>
    1.16 +				<artifactId>sesame-sail-memory</artifactId>
    1.17 +				<version>${sesame.version}</version>
    1.18 +			</dependency>
    1.19 +			
    1.20 +			<dependency>
    1.21 +				<groupId>org.openrdf.sesame</groupId>
    1.22  				<artifactId>sesame-repository-sail</artifactId>
    1.23  				<version>${sesame.version}</version>
    1.24  			</dependency>
    1.25 @@ -290,6 +296,36 @@
    1.26  				<version>${geotools.version}</version>
    1.27  			</dependency>
    1.28  
    1.29 +			<dependency>
    1.30 +				<groupId>org.geotools</groupId>
    1.31 +				<artifactId>gt-epsg-wkt</artifactId>
    1.32 +				<version>${geotools.version}</version>
    1.33 +			</dependency>
    1.34 +
    1.35 +			<dependency>
    1.36 +				<groupId>org.geotools</groupId>
    1.37 +				<artifactId>gt-geometry</artifactId>
    1.38 +				<version>${geotools.version}</version>
    1.39 +			</dependency>
    1.40 +
    1.41 +			<dependency>
    1.42 +				<groupId>org.geotools</groupId>
    1.43 +				<artifactId>gt-data</artifactId>
    1.44 +				<version>${geotools.version}</version>
    1.45 +			</dependency>		
    1.46 +
    1.47 +			<dependency>
    1.48 +				<groupId>org.geotools</groupId>
    1.49 +				<artifactId>gt-swing</artifactId>
    1.50 +				<version>${geotools.version}</version>
    1.51 +			</dependency>
    1.52 +
    1.53 +			<dependency>
    1.54 +				<groupId>org.opengis</groupId>
    1.55 +				<artifactId>geoapi-pending</artifactId>
    1.56 +				<version>2.3-M1</version>
    1.57 +			</dependency>
    1.58 +
    1.59  			<!-- JTS -->
    1.60  			<dependency>
    1.61  				<groupId>com.vividsolutions</groupId>