Strabon

diff runtime/pom.xml @ 0:3435769679f3

Strabon goes mercurial
author Kostis Kyzirakos <kkyzir@di.uoa.gr>
date Fri Jan 27 01:08:32 2012 +0200 (2012-01-27)
parents
children d98da2dead4b
line diff
     1.1 --- /dev/null	Thu Jan 01 00:00:00 1970 +0000
     1.2 +++ b/runtime/pom.xml	Fri Jan 27 01:08:32 2012 +0200
     1.3 @@ -0,0 +1,269 @@
     1.4 +<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
     1.5 +
     1.6 +	<modelVersion>4.0.0</modelVersion>
     1.7 +
     1.8 +	<parent>
     1.9 +		<groupId>eu.earthobservatory</groupId>
    1.10 +		<artifactId>strabon</artifactId>
    1.11 +		<version>3.1.1-SNAPSHOT</version>
    1.12 +	</parent>
    1.13 +
    1.14 +	<groupId>eu.earthobservatory</groupId>
    1.15 +	<artifactId>strabon-runtime</artifactId>
    1.16 +
    1.17 +	<name>Strabon: Runtime</name>
    1.18 +	<description>Runtime dependencies for Strabon</description>
    1.19 +	<packaging>jar</packaging>
    1.20 +	<version>3.1.1-SNAPSHOT</version>
    1.21 +
    1.22 +	<properties>
    1.23 +		<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    1.24 +		<project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
    1.25 +
    1.26 +		<aduna.appbase.version>3.11.0</aduna.appbase.version>
    1.27 +		<spring.version>2.5.6</spring.version>
    1.28 +	</properties>
    1.29 +		
    1.30 +	
    1.31 +	<dependencies>
    1.32 +		<dependency>
    1.33 +			<groupId>org.openrdf.sesame</groupId>
    1.34 +			<artifactId>sesame-queryresultio-sparqlxml-spatial</artifactId>
    1.35 +		</dependency>
    1.36 +		<dependency>
    1.37 +			<groupId>org.openrdf.sesame</groupId>
    1.38 +			<artifactId>sesame-sail-postgis</artifactId>
    1.39 +		</dependency>
    1.40 +		<dependency>
    1.41 +			<groupId>org.openrdf.sesame</groupId>
    1.42 +			<artifactId>sesame-sail-monetdb</artifactId>
    1.43 +		</dependency>
    1.44 +		<dependency>
    1.45 +			<groupId>org.openrdf.sesame</groupId>
    1.46 +			<artifactId>sesame-sail-generaldb</artifactId>
    1.47 +		</dependency>
    1.48 +		<dependency>
    1.49 +			<groupId>org.openrdf.sesame</groupId>
    1.50 +			<artifactId>sesame-queryalgebra-evaluation-spatial</artifactId>
    1.51 +		</dependency>
    1.52 +
    1.53 +		<dependency>
    1.54 +			<groupId>org.openrdf.sesame</groupId>
    1.55 +			<artifactId>sesame-queryalgebra-model</artifactId>
    1.56 +		</dependency>
    1.57 +
    1.58 +
    1.59 +		<dependency>
    1.60 +			<groupId>org.openrdf.sesame</groupId>
    1.61 +			<artifactId>sesame-queryalgebra-evaluation</artifactId>
    1.62 +			 
    1.63 +		</dependency>
    1.64 +
    1.65 +		<dependency>
    1.66 +			<groupId>org.openrdf.sesame</groupId>
    1.67 +			<artifactId>sesame-queryparser-api</artifactId>
    1.68 +			 
    1.69 +		</dependency>
    1.70 +		
    1.71 +		<dependency>
    1.72 +			<groupId>org.openrdf.sesame</groupId>
    1.73 +			<artifactId>sesame-queryparser-sparql</artifactId>
    1.74 +		</dependency>
    1.75 +
    1.76 +		<dependency>
    1.77 +			<groupId>org.openrdf.sesame</groupId>
    1.78 +			<artifactId>sesame-model</artifactId>
    1.79 +		</dependency>
    1.80 +
    1.81 +		<dependency>
    1.82 +			<groupId>org.openrdf.sesame</groupId>
    1.83 +			<artifactId>sesame-sail-api</artifactId>
    1.84 +		</dependency>
    1.85 +
    1.86 +		<dependency>
    1.87 +			<groupId>org.openrdf.sesame</groupId>
    1.88 +			<artifactId>sesame-query</artifactId>
    1.89 +		</dependency>
    1.90 +		
    1.91 +		<dependency>
    1.92 +			<groupId>org.openrdf.sesame</groupId>
    1.93 +			<artifactId>sesame-sail-rdbms</artifactId>
    1.94 +		</dependency>
    1.95 +		
    1.96 +		<dependency>
    1.97 +			<groupId>org.openrdf.sesame</groupId>
    1.98 +			<artifactId>sesame-repository-sail</artifactId>
    1.99 +		</dependency>
   1.100 +
   1.101 +		<!-- GeoTools -->
   1.102 +			<dependency>
   1.103 +				<groupId>org.geotools.xsd</groupId>
   1.104 +				<artifactId>gt-xsd-kml</artifactId>
   1.105 +			</dependency>
   1.106 +
   1.107 +			<dependency>
   1.108 +				<groupId>org.geotools</groupId>
   1.109 +				<artifactId>gt-xml</artifactId>
   1.110 +			</dependency>
   1.111 +
   1.112 +			<dependency>
   1.113 +				<groupId>org.geotools</groupId>
   1.114 +				<artifactId>gt-epsg-hsql</artifactId>
   1.115 +			</dependency>
   1.116 +			
   1.117 +			<dependency>
   1.118 +				<groupId>org.geotools</groupId>
   1.119 +				<artifactId>gt-shapefile</artifactId>
   1.120 +			</dependency>
   1.121 +
   1.122 +		<!-- Aduna Appbase -->
   1.123 +			<dependency>
   1.124 +				<groupId>info.aduna.appbase</groupId>
   1.125 +				<artifactId>aduna-appbase</artifactId>
   1.126 +				<version>${aduna.appbase.version}</version>
   1.127 +				<type>pom</type>
   1.128 +				<scope>import</scope>
   1.129 +			</dependency>
   1.130 +
   1.131 +			<!-- Aduna Commons -->
   1.132 +			<!-- Note: other Aduna Commons dependencies are imported from appbase -->
   1.133 +			<dependency>
   1.134 +				<groupId>info.aduna.commons</groupId>
   1.135 +				<artifactId>aduna-commons-collections</artifactId>
   1.136 +				<version>2.8.0</version>
   1.137 +			</dependency>
   1.138 +			<dependency>
   1.139 +				<groupId>info.aduna.commons</groupId>
   1.140 +				<artifactId>aduna-commons-concurrent</artifactId>
   1.141 +				<version>2.7.0</version>
   1.142 +			</dependency>
   1.143 +			<dependency>
   1.144 +				<groupId>info.aduna.commons</groupId>
   1.145 +				<artifactId>aduna-commons-i18n</artifactId>
   1.146 +				<version>1.4.0</version>
   1.147 +			</dependency>
   1.148 +			<dependency>
   1.149 +				<groupId>info.aduna.commons</groupId>
   1.150 +				<artifactId>aduna-commons-iteration</artifactId>
   1.151 +				<version>2.10.0</version>
   1.152 +			</dependency>
   1.153 +			<dependency>
   1.154 +				<groupId>info.aduna.commons</groupId>
   1.155 +				<artifactId>aduna-commons-net-http-server-embedded</artifactId>
   1.156 +				<version>2.5.0</version>
   1.157 +			</dependency>
   1.158 +
   1.159 +			<!-- Apache Commons -->
   1.160 +			<dependency>
   1.161 +				<groupId>commons-cli</groupId>
   1.162 +				<artifactId>commons-cli</artifactId>
   1.163 +				<version>1.2</version>
   1.164 +			</dependency>
   1.165 +			<dependency>
   1.166 +				<groupId>commons-dbcp</groupId>
   1.167 +				<artifactId>commons-dbcp</artifactId>
   1.168 +				<version>1.3</version>
   1.169 +			</dependency>
   1.170 +			<dependency>
   1.171 +				<groupId>commons-fileupload</groupId>
   1.172 +				<artifactId>commons-fileupload</artifactId>
   1.173 +				<version>1.2.1</version>
   1.174 +			</dependency>
   1.175 +			<dependency>
   1.176 +				<groupId>commons-io</groupId>
   1.177 +				<artifactId>commons-io</artifactId>
   1.178 +				<!-- this is the version that is specified as an optional dependency for fileupload -->
   1.179 +				<version>1.3.2</version>
   1.180 +			</dependency>
   1.181 +			<dependency>
   1.182 +				<groupId>commons-httpclient</groupId>
   1.183 +				<artifactId>commons-httpclient</artifactId>
   1.184 +				<version>3.1</version>
   1.185 +				<exclusions>
   1.186 +					<exclusion>
   1.187 +						<groupId>commons-logging</groupId>
   1.188 +						<artifactId>commons-logging</artifactId>
   1.189 +					</exclusion>
   1.190 +					<exclusion>
   1.191 +						<!-- httpclient includes older codec -->
   1.192 +						<groupId>commons-codec</groupId>
   1.193 +						<artifactId>commons-codec</artifactId>
   1.194 +					</exclusion>
   1.195 +				</exclusions>
   1.196 +			</dependency>
   1.197 +			<dependency>
   1.198 +				<groupId>commons-codec</groupId>
   1.199 +				<artifactId>commons-codec</artifactId>
   1.200 +				<version>1.4</version>
   1.201 +				<scope>runtime</scope>
   1.202 +			</dependency>
   1.203 +
   1.204 +			<!-- Spring framework -->
   1.205 +			<dependency>
   1.206 +				<groupId>org.springframework</groupId>
   1.207 +				<artifactId>spring-aop</artifactId>
   1.208 +				<version>${spring.version}</version>
   1.209 +				<exclusions>
   1.210 +					<exclusion>
   1.211 +						<groupId>commons-logging</groupId>
   1.212 +						<artifactId>commons-logging</artifactId>
   1.213 +					</exclusion>
   1.214 +				</exclusions>
   1.215 +			</dependency>
   1.216 +
   1.217 +			<!-- Compliance tests -->
   1.218 +			<dependency>
   1.219 +				<groupId>edu.lehigh.swat.bench</groupId>
   1.220 +				<artifactId>uba</artifactId>
   1.221 +				<version>1.7</version>
   1.222 +			</dependency>
   1.223 +			<dependency>
   1.224 +				<groupId>edu.lehigh.swat.bench</groupId>
   1.225 +				<artifactId>ubt</artifactId>
   1.226 +				<version>1.1</version>
   1.227 +			</dependency>
   1.228 +
   1.229 +			<!-- JDBC Drivers -->
   1.230 +
   1.231 +			<dependency>
   1.232 +				<groupId>postgresql</groupId>
   1.233 +				<artifactId>postgresql</artifactId>
   1.234 +				<version>9.0-801.jdbc3</version>
   1.235 +			</dependency>
   1.236 +
   1.237 +			<dependency>
   1.238 +				<groupId>mysql</groupId>
   1.239 +				<artifactId>mysql-connector-java</artifactId>
   1.240 +				<version>5.1.15</version>
   1.241 +			</dependency>
   1.242 +
   1.243 +			<!-- various -->
   1.244 +			<dependency>
   1.245 +				<groupId>cglib</groupId>
   1.246 +				<artifactId>cglib</artifactId>
   1.247 +				<version>2.2</version>
   1.248 +			</dependency>
   1.249 +			
   1.250 +			<!-- Testing: JUnit -->
   1.251 +			<dependency>
   1.252 +				<groupId>junit</groupId>
   1.253 +				<artifactId>junit</artifactId>
   1.254 +				<version>4.7</version>
   1.255 +				<scope>test</scope>
   1.256 +			</dependency>
   1.257 +
   1.258 +			<dependency>
   1.259 +				<groupId>monetdb</groupId>
   1.260 +				<artifactId>jdbcclient</artifactId>
   1.261 +				<version>3.0.0</version>
   1.262 +			</dependency>
   1.263 +			<!--
   1.264 +			<dependency>
   1.265 +				<groupId>net.sf</groupId>
   1.266 +				<artifactId>log4jdbc3</artifactId>
   1.267 +				<version>1.2beta2</version>
   1.268 +			</dependency>
   1.269 +			-->
   1.270 +	</dependencies>
   1.271 +</project>
   1.272 +